Just had a dead Toshiba 2,5 hard drive dead, so had to install anew on a new disk. And I've had the strange idea to install all apps anew too.

The trouble is, I need Adobe AIR to install Twhirl. And for some reason, AIR did not. The Console said "kern failure", the install was uncomplete at best. No troubleshooting advice available on Adobe support worked. When I used a different user account and AIR did install, and Twhirl too. So there was something fishy with my account, as save apps, it was cloned from a working system with AIR and Twhirl, it was either AIR in bad mood, or something else doing fishy stuff and preventing me to install.

First, I tried to uninstall what AIR had done, as I did not have the uninstaller in Applications/utilities, I had to do it by hand. Save what's in utilities, AIR is hidden in ~/libraries/framework and in Users/username/libraries/application support.

Then I decided to check all I had installed, and the winner is Flip4mac. Once removed, everything worked fine.

Hope this helps.